Copy + not recognising sky hdd tried fixskymbr and fixskybpb

Any other questions about the software?

Copy + not recognising sky hdd tried fixskymbr and fixskybpb

Postby neb9 » Thu Dec 29, 2011 3:06 pm

Hi, have a samsung sky+ hd box with a 320gb drive, I've been having problems with it - failed recordings, box crashing if I pause etc. So I desided to change the disk, I downloaded copy plus and followed the instructions but Copy + isn't recognising my original sky+ disk. I've tried using fixskymbr and I get drive size is 320gb partition ID=01, this drive is already partitioned. I then ran copy+ again and still no joy so I used fixskybpb and I get - incorrect partition 0 of type 01 found. this does not appear to be a FAT32 partitioned drive.

I can view the drive in windows disk manager and explore it in windows explorer. Does anyone know whats going wrong and how I can get the contents of my drive to be read by copy+?

Posts: 2
Joined: Thu Dec 29, 2011 1:18 pm

Re: Copy + not recognising sky hdd tried fixskymbr and fixsk

Postby simpaty » Sat Jan 28, 2012 7:47 pm

I have got EXACTLY the same issue with my brand new samsung MySKY HD from ITALY. Copy Plus would not recognize it but windows recongnizes it as FST32, In fact I can browse all files!! (no recordings tho)
It could be they have put some kind of protection...
Posts: 2
Joined: Sat Jan 28, 2012 7:44 pm

Re: Copy + not recognising sky hdd tried fixskymbr and fixsk

Postby kos129 » Sun Jan 29, 2012 1:08 am

I do not have much experience with non-uk boxes, but if they are anything like the UK ones there will be two main planner versions (pre-darwin and darwin). Darwin (or Fusion) is the latest version of the UK sky software, this has only been rolled out to the HD boxes and has a completely different planner format to the older firmwares. Copy+ only supports the old, pre-darwin format.

You can determine which format you have by looking at the drive's contents in windows explorer:
  • If there is an FSN_DATA directory present then you have a Darwin version box and Copy+ will not work (there is other software which supports it however).
  • If you have a file named JOPA or JOPA.DB3 and there is no FSN_DATA folder (if there is both then this still means you have darwin, the old databases are not deleted when your box is updated), then you have a legacy device supported by Copy+.
  • If you have neither then you have a format different to any UK box (I have seen a german darwin box which kept the databases on a separate ext3 partition), AFAIK there is currently no software which will support this configuration.

By the way, windows will recognise Sky hard disks as FAT32 as they are labelled as such. They are not exactly FAT32 however, they have a few important modifications (namely, the video files are stored in a different way, which windows will not understand so all the video files will appear to be corrupted if you try and access them through windows explorer).
Posts: 30
Joined: Wed Mar 04, 2009 9:20 pm

Return to Copy+ General Support

Who is online

Users browsing this forum: No registered users and 2 guests