Page 1 of 2

Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Thu Mar 11, 2010 4:00 pm
by njeo
Hi there,

I've completed the transfer from the stock 320Gb WD AVVS drive in the Amstrad Sky+HD DRX780 to a 1.5Tb Western Digital EVDS drive. I used the alpha version of Copy+ which pcbbc kindly supplied.

Taking the machine apart was surprisingly fiddly. I followed the excellent instructions at ... drive.html. I spotted that there are two plastic prongs sticking into the metal box from the plastic frame case, where the viewing card slot is, and so the metal box has to slide back a little bit further than I expected before it became possible to pull the metal inards up and out. That was the only hurdle I encountered. My box did not have torx screws.

I used an Akasa Duo Dock to connect the hard disks to my Dell Zino HD PC via esata. I was initially annoyed/worried when Windows 7 recognised the disk, installed drivers, assigned a drive letter and popped up the Autorun menu - I hope it didn't also decide to put Recycle Bin directories etc on the drive; it probably did if it assigned a drive letter. The transfer of a 9% free drive complete with a full cache of Anytime recordings, to an image file, took about 90 minutes via esata. Copy+ reported a size of 282Gb on the existing drive. The transfer back to the new 1.5Tb drive took 1 hour 18 minutes. I'd definitely recommend esata; I don't know how long that would have taken over USB.

The machine went back together a lot easier. The machine booted up fine although I was nervous as hell that the thing wouldn't work. But it did. The planner reports 89% free. Every existing user recording takes up 1% of the drive, which is nice - I recorded Star Trek The Undiscovered Country, which was either 5% or 8% on the stock drive, can't remember which now, but now it is 1%. Very refreshing not to have to worry about the space implications of a forthcoming recording!

With a 1,500Gb drive I am presuming the available space to me is 1,320Gb which is clearly a vast improvement on 180Gb. Although presumably actual formatted space will be lower. I just hope the assignment of a drive letter by Windows 7 didn't cause any adverse problems.

So many thanks for the fantastic Copy+ software and hopefully everything will be hunkydory going forward :-)

Re: Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Thu Mar 11, 2010 4:10 pm
by njeo
And I notice the new drive I bought has a 32Mb cache but the old one, according to WD's website (, has an 8Mb cache. I don't expect the machine to be any quicker though - navigating the EPG is still as slow as hell, god knows what it'll be like when the planner gets a few more recordings to deal with!

Re: Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Sun Apr 04, 2010 5:25 pm
by Gogga5
Following in your footsteps, I have also just upgraded my DRX780 to the 1.5Tb WD disk. Was a lot more straight forward than I was expecting - down to the very clear instructions on Sky User and Copy+. I had a small issue with the copied recordings not playing but after a rebuild all is well. The new drive feels smoother and is certainly quieter. I too am looking forward to recording with impunity.

Major thanks to the Copy+ guys for the excellent software (even in Alpha version).

Re: Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Sun Apr 04, 2010 8:45 pm
by pcbbc
NP - Glad I could help!

Re: Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Wed Apr 07, 2010 10:32 am
by simonmpoulton
I'm presuming this means that the old boxes are now compatible with 1.5tb drives?
Just asking as the WD 1tb drive I bought was DOA and they are replacing it with a 1.5tb for free.

Re: Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Wed Apr 07, 2010 10:55 am
by pcbbc
No - Only the Amstrad DRX780 boxes, and DXR890/5 boxes on model number 1.0.260.

Traditional wisdom says that all other boxes are still incompatible with drives over 1TB due to (what I assume is) a driver bug.
I have no idea if, or when, the other box manufacturers will update their drivers - probably never unless they release a box with a drive over 1TB.
However please do not just take my word for this, as I do not have the resources to continually test all boxes with different size drives.

If you need to use a 1.5TB drive, and find it doesn't work, use the manufacturers tools to limit the maximum LBA capacity to 1TB or below.

Re: Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Wed Apr 07, 2010 12:08 pm
by simonmpoulton
Thanks for the info, i'll probably give the 1.5tb a whirl in my box and if it doesnt work properly i'll change the settings with the drive tools :)

Re: Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Wed Apr 07, 2010 12:58 pm
by pcbbc
Last time anyone tested 1.5TB drives the symptoms where that the box appeared to work - planner visible and recordings possible - but nothing would playback.
Just a blank/blue screen IIRC.

Re: Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Thu Apr 08, 2010 8:27 pm
by njeo
I thought I'd come back and report on what's been happening with my box. The machine works, and the drive is currently 41% free and I can cope with it being a bit slow - it isn't really that much slower than it was under the stock drive. But I do have some problems with video.

Bottom line; blue screens on initiating playback and also when using live pause, requiring a reboot. Always a tense moment waiting for it to become responsive again.
I can select a recording (any status; anytime, user, viewed, recorded) and start playback, and during the transition from the EPG to the video starting to play, there's a delay of a second or three. During that time, the animated playback symbol is onscreen and rotating as normal. Then, when video starts playing, the time appears underneath ("+93 mins"). Until then, the blue space where that text goes is blank. My box occasionally doesn't get past this transition and does not begin playing back video. The "+93 mins" text does not appear under the playback icon, but the icon carries on rotating as if video is being played. From then on, the EPG operates as normal (navigation is fine, channels can be changed etc) but there's no video or sound on anything and no "+93 mins" text on any recorded programmes until the box is rebooted.

This happens about once every two days and always when starting playing back a recording. The one exception is when it happened after changing from 170 to 101.

I also have a similar problem with live pause, in that I can pause live TV but pressing play doesn't unpause the video. The little animated icon and the lights on the front of the box do what they're meant to, but the picture is frozen. Changing channel takes me to the blue screen scenario above and the blue lights on the front of the box are solid blue.

As I changed the HDD within a few weeks of buying Sky HD, I don't know if it's because of the new drive or because the Sky software has a flaw. The box didn't have these problems in the first week or two of the HDD change.

I do wish the Sky boxes came with a hard reset switch like the Scientific Atlanta Virgin Media V+ boxes :-)

What I might do is bring the free space up to about 80% and see what happens; perhaps having too many entries in the planner means it is taking too long for the system to initiate playback, and the box times out and hangs. Total guess, that, though.

Re: Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Thu Apr 08, 2010 10:47 pm
by simonmpoulton
Incidentally pcbbc, do you happen to know which software is required for a western digital 1.5tb drive to limit the lba to 1tb? Couldnt see anything on WD website.

Re: Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Fri Apr 09, 2010 12:36 am
by pcbbc
I would assume it would be in their Data Lifeguard tools.
But having read the documentation I can see no mention of it :?

Failing that you can probably use the IBM/Hitachi Feature Tool.
I have used this in the past to set the AAM (Acoustic Management) on drives other than IBM/Hitachi ones, and it works well.
In fact it has a nice little test application which randomly steps the heads as you change the AAM so you can actually hear how quiet or loud the drive will be. Very useful!
The documentation here seems to indicate it can be used to set drive capacity on non-IBM/Hitachi products (page 25):
Use with Non-Hitachi /IBM Products
This tool is provided for use only with Legacy IBM ATA hard disk drives and new ATA drives manufactured by Hitachi Global Storage Technologies, however some of the supported parameters of other manufacturer hard disk drives e.g. drive capacity may be changed. Hitachi doesn’t support the use of this tool to change any parameters on ATA drives not manufactured by Hitachi Global Storage Technologies or by IBM and should a user choose to do this, it is done at their own risk.

Re: Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Mon Apr 12, 2010 11:20 am
by njeo
Further to my earlier post, it seems any recording that isn't at the start of the planner is not playing back and giving a blue screen. Anything recorded from 5th April 2010 onwards. Even if I delete earlier recordings to free up some 'earlier' space on planner, the existing recordings after 5th April 2010 still don't play. I had thought that maybe if the recording isn't within the 180Gb of space designated for user recordings on the stock drive, that it wouldn't play, but that doesn't seem to be the case. Will try to delete everything recorded after 5th April 2010 and hope for the best. If I still can't play things back that I record today, then it's back to the stock drive :-( Bloody bugs!!

Re: Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Mon Apr 12, 2010 1:46 pm
by pcbbc
Sorry you are having problems.

njeo wrote:I had thought that maybe if the recording isn't within the 180Gb of space designated for user recordings on the stock drive, that it wouldn't play, but that doesn't seem to be the case.
Perhaps because there isn't any fixed 180GB of space designated for user recordings.
Space is instead allocated on a quote system from ANYWHERE that is free, and the box software tots up the individual recordings to see how "full" the users space on the drive is.

Images of disks which aren't functioning as expected (using my FAT2IMG tool) are always useful.

It's interesting that you are experiencing similar symptoms to the very first 1.5TB upgrader some years ago (using a external eSATA RAID array).
In that case nothing past about 8.5GB was readable on the drive. As the recordings are all stored past this point, the recordings were all unplayable.
What model number is your box showing in system details?

Re: Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Mon Apr 12, 2010 3:16 pm
by njeo
Thanks for your reply.

What I was thinking, but expressing rather poorly, was that maybe the box has summed up 180Gb worth of recordings and considered the drive full, and so anything outside that cannot be played or cannot be found. But that idea fell by the wayside because I was deleting original recordings, which would have brought later recordings down into the initial 180Gb, but those other recordings still remained unplayable.

What is clear is that something changed on midnight 5th April that caused any recordings made on or after that date to record successfully but be unplayable resulting in a blue screen, and for live pause to fail every time it was initiated. I tried every single recording made before 5th April and they were all fine.

The model number for my box is 1_5-016 and version number is 4F30A3.

I have since performed a full system reset on the 1.5Tb drive, then inserted the drive into the PC again on the same esata duo dock connection. I deleted the partition and used my original 320Gb XTV image file to reformat the drive to the full 1500Gb. Perhaps what I should have done was create a new XTV image file from the freshly formatted drive and used that to format to the full 1500Gb - will do that next time!

I have put the drive back in the box but have already had one blue screen scenario :-(. Was recording MotoGP on Eurosport 2 and was using the other input to change from 101 to 102 when I triggered the blue screen. The programme on Eurosport 2 continued to record but I got a blue screen when I tuned into the channel. I terminated the recording after a few minutes and got PART REC.

I thought I'd see what else worked before I rebooted. Tried Sky Active and had the usual "coming next..." dialogue (3 .'s rather than 4) but was told 'Sky Active is not available'. I got "No satellite signal is being received" on 0214 but all others were just blue screens with no message. Signal strengths remained about 55% and 75% for 1st and 2nd input and both were 'locked'. I did a "new install" which, interestingly, completed its channel scan and call back, but nevertheless I still had blue screens on live TV and a recorded programme.

I waited for the HDD to spin down and rebooted, then was - surprisingly - able to play the recording I had just made. The recording said it was 98 minutes, but I knew I had stopped it at 78. So I started playing at 77 minutes and when it rolled over to 78 I got an "End of programme" notice and now the recording length is reported as 78 minutes.

If I carry on having blue screens, then I'll obtain an image for you, and format the drive in the Sky box then take an image of that to reformat to 1500Gb.

Re: Amstrad DRX780 to 1.5Tb WD EVDS

PostPosted: Tue Apr 20, 2010 2:39 pm
by Gogga5
I have been running my box for a few weeks now and while I haven't had all the issues njeo has had, some are familiar and I have had a few interesting ones of my own. I have had the blue screen last Thursday. The best way I can describe it was like only having one satelite input? Only one of 2 scheduled recording were successful that evening. When a program was recording, I had a blue screen when I changed channel. I powered down and that rectified the problem. Over the weekend I noticed another 'interesting' feature while recording House (there were simultaneous recordings). The programme finished transmitting but the box continued recording and would thus not record MOTD. I could not manually stop it. I could watch it and definitely got an 'end of recording message' at 63 mins but the indicator was on and the R showing on the EPG some 40 or 50mins on. The recording reported as failed after I rebooted and I could not watch? I did a planner rebuild and since then I have not been able to recreate the problem - multiple sequential recordings on different channels etc?

My disk is not as full (still showing 80% despite my best efforts) and other than a sluggish planner, I can play everything it successfully records. I set my drive to the full 1500GB (which is how Copy+ showed it) when I changed the drive. I do not have any problems with pausing live telly so far.

I am happy to do some testing on my box if it will help improve things?